Get Started         Best Practices         Developer Guide         FAQ        
Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Fatal Error

Forrest S Feb 01, 2017

After calling startTracking() and aiming my camera at the designated image, the image is recognized, and then I get "Fatal Error: SDK is not ready to add AR items". I'm not sure how to fix this. Any ideas?


( Agent )
Luis Martinell

Feb 02, 2017

This happens when something was not initialized in the proper order. Do you see any other logs in the console? Can you share the code of your viewController?

1 rated
Forrest S

Feb 02, 2017

Thank you for the tip! I ran through my code and I had missed a delegate = self call. I also forgot to add the -ObjC linker flag! So now I can recognize an image and tracking starts, however I am still not seeing my AR content display over the image.
0 rated
Forrest S

Feb 02, 2017

Nevermind, got it!
0 rated

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Couldn't find what you were looking for?

support@catchoom.com
https://cdn.desk.com/
false
catchoom
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete