Get Started         Best Practices         Developer Guide         FAQ        

Why does the 3D model appear white when using CraftAR?

Last Updated: Mar 30, 2016
When 3D models render partially or completely white, it means that the rendering engine has not been able to load some (or all) textures. This can happen for several reasons, we recommend to check the following:
  • Missing textures: make sure that your exported model includes the textures. Sometimes you will need to look for the texture files and add them to the model folder when uploading it using the content creator. Also, make sure the mtl file is present in the zip you upload to the content creator.
  • Wrong texture paths: check the texture paths inside your obj files using a text editor. Some exporters produce absolute paths or Windows routes that can't be handled by external tools.
  • Network connectivity: sometimes poor network connectivity can result in some files not being downloaded.
  • I get an error when uploading my models: Most of these errors are produced by the inclusion of invalid files in the zipped model. Make sure there are not hidden system files like "__MACOSX" or "._DS_Store". Also make sure that the files in your model zip don't contain several extensions like "model.obj.mtl" this can cause problems when importing the model into the Media Library.

Couldn't find what you were looking for?

support@catchoom.com
https://cdn.desk.com/
false
catchoom
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete